iTop ITSM & CMDB по-русски

Модули: Hdd , Отчество, Оперативная память, Токен, wifi

Описание

Эти модули для Combodo iTop 2.x создают отдельные КЕ: Жесткий диск (Hdd),добавляют поле отчество в КЕ человек,RAM (Оперативная память),Токен, Wifi.

https://drive.google.com/folderview?id=0B4-yIU367R7XdUFmaFV2Y0FiZ1k&usp=sharing

Установка

Устанавливаем, как и любой другой модуль в iTop:

  1. Разархивируем и перекладываем папку нужного модуля в itop/extensions/.
  2. Разрешаем редактирование config-файла iTop itop/conf/production/config-itop.php.
  3. Переходим в браузере http://my-itop/setup и выбираем “Upgrade an existing iTop instance”.
  4. На предпоследнем шаге ставим галочку напротив названия модуля и устанавливаем.
  5. Готово.

Как раз не хватает модуля hdd. как он прицепляется к устройствам?
Ссылка не работает

К устройствам пока не прицепляется, в процессе.
Устанавливается в систему как отдельное независимое КЕ.
https://drive.google.com/folderview?id=0B4-yIU367R7XdUFmaFV2Y0FiZ1k&usp=sharing
Ссылка должна работать.

Сделал обновленные модули hdd позже выложу с инструкцией

В шапке ссылка на уже обновленные модуль HDD?

нет, обновленные пока не загружал.

Так может быть уже пора загрузить? =)

Постараюсь в течении дня.
Там модуль hdd завязан с модулем PC, надо вспомнить как эт все работает что бы корректно описать.)

https://drive.google.com/folderview?id=0B4-yIU367R7XMmtXcXdKanp1dGs&usp=sharing
Обновленные модули.
Устанавливать все вместе.
Модули добавляют:




Модули делались под мою организацию, возможно для ваших целей надо будет менять поля.
В любом случаи если будут вопросы, спрашивайте, помогу.

Так же изменяется статус на
> > > Выдано

>     >     	<value id="Disposed">На складе</value>
>     >     	<value id="Invalid">Требуется ремонт</value>
>     >     	<value id="Repair">Сдано в ремонт</value>
>     >     	<value id="Decommissioned">Снято с учёта</value>
>     >     	<value id="Utilized">Утилизировано</value>
>     >     	<value id="Returned">Возвращено поставщику</value>

после установки модулей статусы у ваших данных сменятся на “Неизвестно” Будьте аккуратнее.
Если смена статусов не требуется то просто удалите код из модуля Status
> >

>             <values>
>             <value id="Deployed">Выдано</value>
>             <value id="Disposed">На складе</value>
>             <value id="Invalid">Требуется ремонт</value>
>             <value id="Repair">Сдано в ремонт</value>
>             <value id="Decommissioned">Снято с учёта</value>
>             <value id="Utilized">Утилизировано</value>
>             <value id="Returned">Возвращено поставщику</value>
>             </values>
>             <sql>status</sql>
>             <default_value></default_value>
>               <is_null_allowed>true</is_null_allowed>
>                             </field>
1 Симпатия

Большое вам спасибо за ваш вклад =)

Добрый день. Поставил эти модули пачкой и после этого возникла проблема.
Гугл и другие браузеры жалуются на не безопасные скрипты и криво загружают страницы iTop. Можно конечно указать, что бы они игнорировали это, но хотелось бы вернуть всё в нормальный вид.
ITop развёрнут на убунте 14 работает через nginx по https, установлен бесплатный сертификат от wosign.com. До этого проблем никаких не было.
И самое печальное, то что не сделал бэкап. :((
Сами модули удалил.

Если кто сталкивался с таким, помогите.

Собственно проблему осознал, но почему она возникла не понятно.
Часть ссылок в теме страницы неправильно определяют адрес (http вместо https), ну и соответственно браузеры и ругаются на незащищённое соединение.
Неправильно отрабатывается вот этот код (utils::GetAbsoluteUrlAppRoot().‘css/dragtable.css’);

Привет, @NisSon. При установке не забыл поправить App root url с http://… на https://… ?

1 Симпатия

Блиииннн.
Переустановил с https://… Заработало.
Вот что странно, до этого ставил пару модулей и всё норм было.
Огромное спасибо.

Добрый вечер.
Стояла часть модулей из первоначальной версии.
Пробую установить поверх новые модули (все сразу), получаю следующую ошибку:

Failed to issue SQL query: query = ALTER TABLE physicaldevice CHANGE status status ENUM(‘Возвращено поставщику’,‘Выдано’,‘На складе’,‘Сдано в ремонт’,‘Снято с учёта’,‘Требуется ремонт’,‘Утилизировано’), ADD LAD VARCHAR(255) DEFAULT ‘’, ADD date_of_accounting DATE, ADD date_of_leasing TEXT, ADD date_of_retirement TEXT, ADD date_of_repair TEXT, ADD date_of_utilization DATE, ADD date_of_decommission DATE, ADD Track_Number TEXT, ADD Windows_Number TEXT, mysql_error = Data truncated for column ‘status’ at row 1, mysql_errno = 1265

Установка останавливается на 40%. Не подскажете, как быть?

Нет, я откатился, конечно. Но установить всё равно хочется. )
Можно как-то удалить старый модуль? Думаю, дело в нём.

Пишлось удалить код со статусами. Всё встало, но есть косяк.
При создании модели HDD в перечне “тип устройства” HDD недоступен.

Вроде всё сделал. ))) Выложу на днях с изменениями, если актуально.
ОЗУ тоже привязал к ПК. Странно, что это сразу сделали.

Это были мои первые опыты с модулями)
Как вы привязали озу к пк.
Я например сделал так.
В ке ПК планки ОЗУ не отображаются.
Зато в ке ОЗУ показывает на каком пк установлено.